Start a new topic

DbVis 6.0.8: table indexes tree view not good?

[This topic is migrated from our old forums. The original author name has been removed]
[Attachment has been removed.]

Hi, I have a problem with the indexes in the tree view of the connections pane not displaying correctly. If I expand an indexes node under Database -> dbname -> Tables -> tablename -> indexes it shows "(null) ((null): (null))" for all the indexes belonging to this table (see screen shot). If I then click on one of these (null) entries the right hand side shows what the index is. If I click on the node labelled 'Indexes' under here, the right hand side shows all indexes for the whole database, not just the indexes for this table (see screen shot). Is this fixable? Product: DbVisualizer Personal 6.0.8 Build: #1297 (2008/02/24 21:48) Java VM: Java HotSpot(TM) Client VM Java Version: 1.5.0_12-b04 Java Vendor: Sun Microsystems Inc. OS Name: Windows XP OS Arch: x86 OS Version: 5.1 Informix Dynamic Server 11.10.TC2W1 IBM Informix JDBC Driver for IBM Informix Dynamic Server 3.00.JC3

[This reply is migrated from our old forums. The original author name has been removed]

Re: DbVis 6.0.8: table indexes tree view not good?
Thanks Roger - that all looks good now. Regards, Bryce.
[This reply is migrated from our old forums.]
[Attachment has been removed.]

Re: DbVis 6.0.8: table indexes tree view not good?
Bryce, I have made a few fixes now in the database profile for Informix that hopefully solves the Index issues. Save it as: *DBVIS-HOME\resources\profiles\informix.xml* Please let me know whether it works better. Best Regards Roger
[This reply is migrated from our old forums.]

Re: DbVis 6.0.8: table indexes tree view not good?
Hi Bryce, Thanks for reporting this. We will look into it. Best Regards, Hans