Start a new topic

Cannot use a Commit Batch Size of 1000. How to configure?

[This topic is migrated from our old forums. The original author name has been removed]

Hi, I'm using DbVisualizer Pro 9.1.9 against Informix 12.10 and Oracle 12c. When importing table data from a file in CSV format i see commit batch sizes of 100 even if i change the setting in the Database Connection Properties for Oracle, Category Transaction, for example to 1000. How to setup the commit batch size? Thanks for any help and hint. Regards, Uwe

[This reply is migrated from our old forums. The original author name has been removed]

Re: Cannot use a Commit Batch Size of 1000. How to configure?
Hi Roger, Thanks for the reply via my support call. To summarize: The Commit Batch Size is used when working against the database in question, but the display on the GUI log shows 100 row steps. For me the thread is answered. Regards, Uwe
[This reply is migrated from our old forums.]

Re: Cannot use a Commit Batch Size of 1000. How to configure?
Uwe, You can enable debug of DbVisualizer in Tools->Debug Window (don't enable JDBC debugging). Then re-run the import. Post the debug log using Help->Contact Support and we will have a look at it. Regards Roger
[This reply is migrated from our old forums. The original author name has been removed]

Re: Cannot use a Commit Batch Size of 1000. How to configure?
Hi Roger, Thanks for the advice but it did not help. Now the Default settings is back to 100, but for my specific Informix connection i set it to 1000 but i still see 100 row jumps in the GUI log. Any other ideas? Regards, Uwe
[This reply is migrated from our old forums. The original author name has been removed]

Re: Cannot use a Commit Batch Size of 1000. How to configure?
Hi Roger, Thanks for the hint. I changed via Tool Properties -> Database -> Informix --> Transaction to the Default values. Afterwards i did this for the Informix Connection in question. In both cases the value is 100. I restarted DbVisualizer and changed the setting for my Informix Connection to 1000, saved it. I then imported the data as before .. i still see 100 jumps on the GUI log. Is there a possibility to verify via a trace that DbVisualizer uses? Regards, Uwe
[This reply is migrated from our old forums.]

Re: Cannot use a Commit Batch Size of 1000. How to configure?
Hi Uwe, If you change the Commit Batch Size in Tools->Tool Properties and in the Databases tab for any of your databases, these settings will only apply to database connection that have not overridden the default values. Overriden settings are specified in the connection Properties tab. If you would like to change the size for all of your connections for a specific database make sure you for each of the database connections use the default values. I suspect there might me a mismatch here and that may explain that 100 is still used. Do this in the connection Properties tab and in the Transaction category for the database connections, click the Defaults button and then Revert Selected when prompted. Try this and let me know if it gives the desired commit size. Regards Roger