Start a new topic

turn off auto increase of auto reload function

[This topic is migrated from our old forums. The original author name has been removed]

Hi you all

first of all we use DbVisualizer 5.0 Personal on Windows XP.

we have a problem with the auto reload function in DB Visualizer. we use the Monitor window to every minute auto execute one query to keep the connection to the DB2 System alive. that all works perfectly but if we execute a query manually that takes longer than 1 minute the auto reload function increase the auto reload time. this is normal and described in the following user manual entry:
http://www.minq.se/products/dbvis/doc/main/doc/ug/useCharts/useCharts.html#mozTocId535279

[QUOTE]
Note: The specified number of seconds may be increased automatically by DbVisualizer if the total execution time for all monitors is longer than the specified value.
[/QUOTE]

but the problem is, our DB2 system accepts only a timeout of max. 3 minutes. that means if the autoreload time is increased to more than 3 minutes DbVisualizer gets disconnected from the DB2 system after this 3 minute timeout. and thats no the sense of our keep alive query.

now my question, is it possible wo turn this auto increase function off?

Thank you in advance..

-Will

[This reply is migrated from our old forums. The original author name has been removed]

Re: turn off auto increase of auto reload function

hi roger, thank you for the fast answer...

but the problem is whlie the query with the long duration is running the auto reload time will be increased. and after the long query is executed the auto reload is still about 600 seconds. that means the next keep alive query is sent after 10minutes which is definitly to late to keep the session alive.

while the long query is running, it is not necessary to execute the keep alive query because while the long query is executed the connections is still alive. but after the long query it is necessary that the keep alive query is executed every minute, so that the connection always stay alive.

so is it possible to reset the auto reload time to 1 minute after the query with the long duration is completed?

im sorry about my explaination, i hope its no to hard to understand :-) as you see, im no an english geek!

but thank you for the patience and help..

-Will

[This reply is migrated from our old forums.]

Re: turn off auto increase of auto reload function
Will, Ok that explains. I think an "Auto Adjust" setting should do what you want. Disable it will not affect the Auto Reload timer. The side effect of having it disabled is that the execution may not be executed at an exact interval, but I think in this scenario it's of less interest. I'll add this to the future list. Thanks! Regards Roger
[This reply is migrated from our old forums. The original author name has been removed]

Re: turn off auto increase of auto reload function
Okay that would be very cool if this could be added to one of the next versions. thank you for the good support... kind regards -Will
[This reply is migrated from our old forums.]

Re: turn off auto increase of auto reload function
Will, Just to notify you that there is a new "Adjust" setting in the Monitor window. You find this in DbVisualizer 7.0.5. Best Regards Roger
[This reply is migrated from our old forums.]

Re: turn off auto increase of auto reload function
Will, If the monitor fail to execute within 3 minutes then I assume you will be disconnected anyway, even if the auto increase was not there? Currently it is not possible to turn off this. Regards Roger