Start a new topic

Two date bugs: Import Table Data and Grid Filter

[This topic is migrated from our old forums. The original author name has been removed]
[Attachment has been removed.]

Hi there, if've encountered a new problem with the "Import Table Data" function. It seems, that it's not possible to import rows containing an empty date field. A screenshot is attached to show the situation. Rows containing a date field are imported correctly, but the ones without are ignored leaving a me with a messed up table ;-) The second thing I've noticed is, that the date format in "Tool Properties" are ignored in the filter field (grid view) So if I want to filter for a date in the grid, I've to use "YY-MM-DD". In "Tool Properties" I've defined "dd-MM-yyyy". I'm not sure if I'm doing something wrong here or if it's a bug. This is my connection info: Informix Dynamic Server 9.40.HC2 IBM Informix JDBC Driver for IBM Informix Dynamic Server 3.00.JC3 Thanks for looking into that! Dirk

[This reply is migrated from our old forums. The original author name has been removed]

Re: Two date bugs: Import Table Data and Grid Filter
Hi Roger, no that's awkward, more like challenging ;-) It would be easier though, if I could define a string for the server . The DBDATE Parameter of informix' Client-SDK seems to be ignored by JDBC. The ODBC connection notices this parameter, as well as the unix shell.
[This reply is migrated from our old forums.]

Re: Two date bugs: Import Table Data and Grid Filter
Dirk, Thanks. (I thought you meant the Quick Filter feature). The table filter you specify in DbVis is actually a WHERE clause that is appended to the SELECT statement used to fetch the rows. In this context you need to supply date, time and timestamp data in a format that the DB server can understand. I know this is awkward. Best Regards Roger
[This reply is migrated from our old forums. The original author name has been removed]
[Attachment has been removed.]

Re: Two date bugs: Import Table Data and Grid Filter
Hi Roger, sorry for the delay of my post. Here is what I've meant. Greets Dirk
[This reply is migrated from our old forums.]
[Attachment has been removed.]

Re: Two date bugs: Import Table Data and Grid Filter
Dirk, > The second thing I've noticed is, that the date format in "Tool Properties" are ignored in the filter field (grid view) > So if I want to filter for a date in the grid, I've to use "YY-MM-DD". In "Tool Properties" I've defined "dd-MM-yyyy". > I'm not sure if I'm doing something wrong here or if it's a bug. The quick filtering is using the same format as set in tool properties. I just tried with various formats and it works for me (see screenshot). Can you please try again and post a screenshot if it still fail? Regards Roger
[This reply is migrated from our old forums.]

Re: Two date bugs: Import Table Data and Grid Filter
Hi Dirk, I'm working on improvements in the Import area for the next release, so I'll have a look at this as well. Best Regards, Hans