Start a new topic

Postgres: removing 'public' from queries in query builder

[This topic is migrated from our old forums. The original author name has been removed]

Starting to play with PostgreSQL 9.0 beta. If I use the query builder then I have to drag objects from Databases > My DB name > Schemas > Public > Tables to build up the query. The resulting SQL contains table and column references prefixed by "public.", e.g. public.table or public.table.column. This obviously works but looks a bit messy. SQL commander accepts references without this prefix, is there a way to get Query Builder to generate less fully qualified references?

[This reply is migrated from our old forums.]

Re: Postgres: removing 'public' from queries in query builder
Hi Ed, Just wanted to tell you that in the just released 9.0 version we have addressed the issue with tabs at the bottom by moving them or using another type of control for the selection: http://www.dbvis.com/doc/relnotes/?version=9.0 Best Regards, Hans
[This reply is migrated from our old forums.]

Re: Postgres: removing 'public' from queries in query builder
Ed, Thanks for your suggestions. We'll take a look into this. Regards Roger
[This reply is migrated from our old forums. The original author name has been removed]

Re: Postgres: removing 'public' from queries in query builder
You're a star, thank you, that works. Not for the first I'll observe that it is very confusing to find some panes such as Connection Properties have selectable tabs (or mode controls) at top and bottom, while the query builder has 3 sets of controls, at top centre and bottom. The (IMHO) inconsistency lies in there being two sets of controls which affect a pane's appearance. For consistency all controls affecting the selection of a pane's content should be in one place such as along the top of the relevant pane. So that e.g. in the Connection properties the Connection/Properties buttons would be arranged immediately below the 4 buttons at top. I'd also be tempted to experiment with icons.
[This reply is migrated from our old forums.]

Re: Postgres: removing 'public' from queries in query builder
Ed, Visit the Connection Properties and select the Qualifiers category. Now uncheck the "Qualify Objects with Schema/Database->Auto Completion/Query Builder". Press Apply and try. Regards Roger