Start a new topic

Format command loses variable on Linux

[This topic is migrated from our old forums. The original author name has been removed]
[Attachment has been removed.]

Good afternoon. I'm having an issue where variables are being lost when I attempt to format the SQL. From what I can tell, it is losing the value of the variable and replacing it with [dbvis - vX] where 'X' is the number of the variable. i.e. if there are 3 variables, then it will be replaces with [dbvis - v0] through [dbvis - v2]. Please see attached for simple example. OS: Red Hat Enterprise Linux Workstation release 6.3 (Santiago) I originally noted this on dbvis v 9.0_1866 beta and then reproduced the 9.0 release which has the same behavior. I have not tested on 8.x RHEL. This behavior may be Linux specific as testing this on 8.x / 9.x release in a Win7 VM produced the proper and expected formatted sql while retaining the values.

[This reply is migrated from our old forums.]

Re: Format command loses variable on Linux
Hi Christos, Please post (or email to support@dbvis.com) the statement before and after formatting. Best Regards, Hans
[This reply is migrated from our old forums. The original author name has been removed]
[Attachment has been removed.]

Re: Format command loses variable on Linux
Hello, I experience the same issue. My environment is as follows: Product: DbVisualizer Pro 9.0.9 Build: #1943 (2013/08/28 08:40) Java VM: Java HotSpot(TM) 64-Bit Server VM Java Version: 1.7.0_25 Java Vendor: Oracle Corporation OS Name: Windows 8 OS Arch: amd64 OS Version: 6.2 Please see attachment for variable delimiter settings. Thanks. Edited by: Christos Avrilionis on Sep 10, 2013 2:43 PM
[This reply is migrated from our old forums.]

Re: Format command loses variable on Linux
Hi Andre, I cannot reproduce this. Which DbVisualizer version are you using? What Variable Delimiter setting do you have in Tool Properties? Best Regards, Hans