Start a new topic

Memory problems while displaying table with varbinary [mssql]

[This topic is migrated from our old forums. The original author name has been removed]

Hi, I have table with varbinary data, which contains pdfs with +-5MB size. The data grid is unable to display the table because it ends with Virtual Memory Problem! error message. How can I disable fetching varbinary data for specific table/database/globally? Properties for "Presentation of Binary/BLOB and CLOB data" are set to "By size". Thank you.
1 Comment

[This reply is migrated from our old forums.]

Re: Memory problems while displaying table with varbinary [mssql]
Hi Juraj, Unfortunately, it is not currently possible to avoid loading VARBINARY or BLOB columns until they are viewed. You have three options: 1) Load fewer rows in the Data tab by setting Max Rows or specify a filter that only returns the rows you need to see 2) Allocate more memory to the DbVisualizer Java VM, please see this FAQ: 3) Work with the table in the SQL Commander instead after running a SELECT that does not include the VARBINARY column. I hope this helps. If not, please don't hesitate to get back with more questions. Best Regards, Hans