Start a new topic

Can't change Java memory allocation 9.1.3 Windows 7

[This topic is migrated from our old forums. The original author name has been removed]

I changed the Java memory allocation using Tools | General | Java edit box, but entered -Xmx4096 instend of -Xmx4096m. Now 9.1.3 won't start - brief flicker of start up logo - then dies. Editing the dbvis.vmoptions file does nothing. Tried uninstalling and reinstalling -- no change -- still won't start. I suppose there's something in the Windows registry that uninstall doesn't clear out -- but where? Basically 9.1.3 is unusable at the moment.

[This reply is migrated from our old forums.]

Re: Can't change Java memory allocation 9.1.3 Windows 7
Hi Kris, you need to remove a file in your .dbvis folder to reset the overridden value. Please see the warning note in this FAQ for the exact file name depending on platform: http://confluence.dbvis.com/pages/viewpage.action?pageId=3146118 Best Regards, Hans
[This reply is migrated from our old forums. The original author name has been removed]

Re: Can't change Java memory allocation 9.1.3 Windows 7
I'm having the exact same problem with Mac 10.10 and DBViz 9.2.6. I tried to change my memory settings via the "override" option in the DBViz preferences. I think I set the memory too high, the program crashed and now won't start. I looked for the vmoptions.txt in /Applications/DBvisualizer.app, but that is set correctly and I'm still stuck. My boss just bought a license for me too, so I hope I'm not stuck. Any advice on a fix or workaround? Edited by: Kris Eberwein on May 1, 2015 3:41 AM
[This reply is migrated from our old forums.]

Re: Can't change Java memory allocation 9.1.3 Windows 7
Hi, Great you found the solution. The user specific user.vmoptions file was introduced in DbVisualizer 9.1.3 along with the UI in Tool Properties to modify it. Regards Roger
[This reply is migrated from our old forums. The original author name has been removed]

Re: Can't change Java memory allocation 9.1.3 Windows 7
Thank you. You have solved the problem. I have plenty of RAM (32GB), but I entered a number:that was too small: 4096 rather than 4096M. That was too small for DBVis to start. I didn't know that there was another copy of vmoptions in C:\Users\\.dbvis. I tried to edit the copy in C:\Program Files\DbVisualizer Thank you again for the rapid solution.
[This reply is migrated from our old forums.]

Re: Can't change Java memory allocation 9.1.3 Windows 7
Hi, You have probably entered a too high number for -Xmx Open a Windows Explorer and navigate to C:\Users\\.dbvis In that folder you will find user.vmoptions. Open it in a text editor and lower the setting of -Xmx and the try start DbVisualizer. How much RAM do you have available? Make sure -Xmx is higher than 2/3 of RAM that is available. Regards Roger