Start a new topic

Running Low On Memory and Heap Size

[This topic is migrated from our old forums. The original author name has been removed]

I just upgraded from version 9.1.3 to 9.1.5. I have some large scripts that I run and I am getting the "running low on memory" warning. I have increased the maximum memory to 4096m, but I am still getting the warning and the maximum heap size still says 455M. I have changed the -Xmx setting through the Tools page and also by editing the dbvis.vmoptions file directly. Is this happening for anyone else? Does anyone have an idea about how to fix it? Thanks in advance.
1 Comment

[This reply is migrated from our old forums.]

Re: Running Low On Memory and Heap Size
Hi Franklin, If you want to run very large scripts, we recommend that you use the @run command instead of loading the script in an SQL Commander. You can also log to file instead of to the GUI, since all the log entries also use up memory. See the Users Guide for some more on this: You should only have to change the Xmx setting in one place. To figure out what may be wrong, please send us a screenshot of the Too Properties setting and your dbvis.options file. Best Regards, Hans