Start a new topic

Getting error "The database connection has been lost".Works for DB 8.x

[This topic is migrated from our old forums. The original author name has been removed]

Hi, We have developed our own JDBC driver (modeled on MySQL). We were using DBVisualizer 8.x to execute our queries. Now, with 9.x, we are able to connect and browse the data using the connections view, but we are not able to execute any queries on our connection using SQL Commander. The error that we are consistently getting is: "The database connection has been lost." It gives us the option to reconnect and execute, but that still gives the above error everytime. Not sure what changed between 8.x and 9.x versions since our driver is the same, but could it be the database auto-detect feature that is causing this issue? I didn't find anything specific in the release notes of DBVis 9.x. Any help to understand the problem will be greatly appreciated! I am attaching the DB Visualizer generated. Also, please note that I ran DBVisualizer with Administrator privileges on Windows 7. Thanks, Sayali.

[This reply is migrated from our old forums.]

Re: Getting error "The database connection has been lost".Works for DB 8.x
Hi Sayali, Great that you found it; I was going to point you to that FAQ :) Since you develop your own JDBC driver, you could also implement the Connection#isValid() method to return true or false depending on what a "ping" on the connection reveals. Since you ran into this problem, it seems like your driver implements the method but always returns false. Best Regards, Hans
[This reply is migrated from our old forums. The original author name has been removed]

Re: Getting error "The database connection has been lost".Works for DB 8.x
Ok, I found this in the FAQ section which helped me solve my problem. http://confluence.dbvis.com/pages/viewpage.action?pageId=3146430 I guess I should've searched there first :p HTH others as well! Thanks, Sayali.