Start a new topic

Is there a way to turn off preparser?

[This topic is migrated from our old forums. The original author name has been removed]

Hello! Is there a way to turn off preparser? I use Intersystems Caché Database and if you have your own function in the database you have to call it like this $$functionName^Function(), the SQL preparser tags "^" as a lexical error and doesn't execute the SQL. Thanks!

[This reply is migrated from our old forums. The original author name has been removed]

Re: Is there a way to turn off preparser?
Alright! Thanks Han! Probably an error on the JDBC driver, since the built in sql tool doesn't throw this error.
[This reply is migrated from our old forums.]

Re: Is there a way to turn off preparser?
Hi Gabriel, It is the database that generates that error message. In this post you see that the same kind of error message is issued for another error when using a their native tool: http://www.legacy.cachemonitor.de/support/forum/4-general/424-how-to-execute-two-queries I suggest that you contact Cache for help with this problem. Best Regards, Hans
[This reply is migrated from our old forums. The original author name has been removed]

Re: Is there a way to turn off preparser?
Hi Hans! Thanks for the reply. When I disable preprocess script it stills throws an error. This is the error: SQL preparser error: Lexical error at line 0, column 151. Encountered: "^" (94), after : "" The SQL: SELECT SUM($$FloatVal^Function(Produtos_NRQtd)) AS Produtos_NRQtd FROM VENNota_Produtos WHERE N.DTEmissao >= TODATE('01/01/2014', 'dd/MM/yyyy') AND N.DTEmissao
[This reply is migrated from our old forums.]

Re: Is there a way to turn off preparser?
Hi Gabriel, Do you mean DbVisualizer's preparser? If so, you can turn it off by unchecking "Preprocess script" in the results area of the SQL Commander, but I don't see that it should have a problem with the "^" character, unless you have changed the settings for statement delimiters or similar in Tool Properties to include that character. Best Regards, Hans