Start a new topic

How to Setup new driver for Presto DB

[This topic is migrated from our old forums. The original author name has been removed]

Hi, I am trying to connect to Presto using DBVis (V9.2.12). I downloaded the presto-jdbc-0.123.jar from https://prestodb.io/docs/current/installation/jdbc.html and tried to add a driver but it did not come up with any driver class. Can you please help? Thanks, Sudipta

[This reply is migrated from our old forums.]

Re: How to Setup new driver for Presto DB
Hi Sudipta, Great, I'm glad that fixed it. Best Regards, Hans
[This reply is migrated from our old forums. The original author name has been removed]

Re: How to Setup new driver for Presto DB
Hi Hans, I used Java version 8 which you had pointed out earlier and it works fine. Thank you so much for your help with this. Sudipta
[This reply is migrated from our old forums.]

Re: How to Setup new driver for Presto DB
Hi Sudipta, Nope, sorry but I cannot see anything in the logs. Do you have read access to the JAR file? If you open it, can you see the com\facebook\presto\jdbc\PrestoDriver.class file? If you have read access and the JAR file contains the driver class file, I'm not sure what may be wrong. I would suggest reinstalling DbVisualizer with a bundled Java VM and see if that fixes the problem. You can download the installer here: http://www.dbvis.com/download/ Best Regards, Hans
[This reply is migrated from our old forums. The original author name has been removed]
[Attachment has been removed.]

Re: How to Setup new driver for Presto DB
Hi Hans, I opened the Debug window and enabled the DBVis and Driver debugging and then tried to create the driver but I don't think there was any logging for that. I have attached the 2 files here in case you spot anything. Thanks, Sudipta
[This reply is migrated from our old forums.]

Re: How to Setup new driver for Presto DB
Hi Sudipta, I tested with the same JAR file, presto-jdbc-0.123.jar, and I'm also on a 64-bit architecture (but Mac OS X). I doubt that is the problem, but I also use Java 8 and you use Java 7. That may make a difference. One way to get a clue may be to open Tools->Debug Window and enable debugging for DbVisualizer. Then load the JAR files again and include the debug output in your reply. Best Regards, Hans
[This reply is migrated from our old forums. The original author name has been removed]
[Attachment has been removed.]

Re: How to Setup new driver for Presto DB
Hi Hans, Thanks for getting back so quickly. I followed the same steps as in the doc you mentioned. I had done the same thing previously for Hive and it worked fine. I have attached a screen capture of what I am doing. In the jar archive, I can see the driver class you mentioned as well. Are you using this file: presto-jdbc-0.123.jar from https://prestodb.io/docs/current/installation/jdbc.html I am using a 64bit m/c.. Does that have anything to do with it? I am on a 64 bit m/c. Product: DbVisualizer Pro 9.2.12 [Build #2486] OS: Windows 7 OS Version: 6.1 OS Arch: amd64 Java Version: 1.7.0_79 Java VM: Java HotSpot(TM) 64-Bit Server VM Java Vendor: Oracle Corporation Java Home: c:\program files\java\jre7 DbVis Home: C:\Program Files\DbVisualizer User Home: C:\Users\sarkars PrefsDir: C:\Users\sarkars\.dbvis SessionId: 273 BindDir: C:\Users\sarkars\.dbvis\[0] Thanks, Sudipta
[This reply is migrated from our old forums.]

Re: How to Setup new driver for Presto DB
Hi Sudipta, I downloaded the JAR file and loaded it into the Driver Manager and it shows a driver class: com.facebook.presto.jdbc.PrestoDriver How did you add it to DbVisualizer? Please see this part of the Users Guide for how to do it: http://confluence.dbvis.com/display/UG92/Installing+a+JDBC+Driver Best Regards, Hans