Start a new topic

Null schemas in Dbvis 9.5

After upgrading to 9.5, I cannot see any schema names when using the PrestoDB JDBC driver.  The schemas show up as nulls as shown below:

This does not occur with older versions of dbvis (9.2.x) 

Also I have tried different versions of the JDBC driver and getting the same result.

This is on the mac client.

Hi Mohit,

Please ask questions or report question using either the forum or submit a ticket, not both. That just makes it harder for us to keep track. I have answered the ticket you submitted already, but I include it here as well in case others run into this.

Did you try with the current driver Presto driver version (1.150), available here:

I also see that you set Xbootclasspath in Tool Properties, in the General category. That may cause invalid driver classes to be found, so please remove or comment out that setting by adding a hashmark first on that line.

If it still doesn't work, please open Tools->Debug Window and enable debugging for DbVisualizer. Then connect again and include the debug output in your reply. 

Let's keep the follow ups with the ticket. When we get a final resolution, I can post it here in the forum as well.

Kind regards,


An update on this, please set Database Type to Generic instead of Auto Detect to work-around this issue while we look into what is causing it.

Login or Signup to post a comment