Start a new topic

Disable CTRL+ENTER to execute entire sql commander buffer

 I frequently highlight and ctrl+enter to execute some code inside of the sql commander. However it's also set up so if nothing is highlighted and you press ctrl+enter it executes EVERYTHING on that page immediately. I move pretty fast sometimes and if I miss click after highlighting or something and press ctrl+enter it starts executing the entire buffer. I've shot myself in the foot a couple times when it modifies production data due to some command I had earlier in that window. I do my best to avoid it from several different approaches but I still think this is a dangerous default behaviour. I'd recommend either making it it's own separate key binding (that's different), or at least having a pop up confirmation box (hey you're about to execute 30 commands and 500 lines of code, continue?). Two other people on my team have at least made this same costly mistake at least once as well. If there is a way around this please let me know!

You are right, I have exaclty the same experiences.

One vay round is to disable the shortcut for 'Execute' and just stick to Execute current (Ctrl - period by default) which takes the current statement or highlighted part. You will be missing a shortcut for applying a filter then, though.


Good idea. I will open a new ticket for it.



Login or Signup to post a comment