Start a new topic

Buffer content pastes twice when using cmd+v on OSX

I'm using latest 9.5.6 version with Java version 1.8.0_121 running on OS X El Capitan 10.11.6.


Sometimes when pasting with keyboard shortcut cmd+v I have duplicate output.


Yes, exactly. DbVisualizer says it uses Java Version: 1.8.0_112. I have JDK 1.8.0_121 installed as well which behaves the same. I don't know exactly how to reproduce this bug. It occurs randomly.

Daniil,


We've got reports that using Java 1.8.0_112 fixes it. You said in one of your previous posts that you've tried DbVisualizer with the embedded JVM but with the same result. The embedded Java version is 1.8.0_112 which makes me a bit puzzled.


I just want to double-check that you tried DbVisualizer with 1.8.0_112 and that the twice-paste is there as well?


Regards


Roger

Here is the video where you can see the bug: http://take.ms/VTbBt

I think it's DbVisualizer issue rather than JVM one. I don't have such issue in IntellJ IDEA and other JVM-based software.

Updated to latest Sierra 10.12.4 (clean) install and the issue still persists.

Hi Daniil,


I'm sorry, but I have no other ideas. I googled on "Java version 1.8.0_121 running on OS X El Capitan 10.11.6 paste issue" but come up empty.


Best Regards,

Hans

Okay. I don't have this problem but I'm on MacOS 10.12, not 10.11.

 

Yes, tried with embedded jvm and tried updating to latest jvm. Same here.

Have you tried using the version of DbVisualizer that includes its own Java runtime (ie. the "With Java VM" choice on the downloads page)?

Hi. Sorry for late reply. I have some items in Accessibility features enabled but disabling them doesn't make any difference.

When this bug occurs I have to restart application or paste contents with "Paste" context menu option and not cmd+v

Hi Daniil,


This is something we have not heard about before, and all DbVisualizer developers use macOS in our daily work and have not experienced what you describe. Do you have any Accessibility features enabled, see Security & Privacy (under the Privacy tab) in the macOS System Preferences app. If you do, does disabling them make a difference?


Best Regards,

Hans

Login or Signup to post a comment