Start a new topic

SAS database support

I have (more or less) successfully configured SAS connection in DbVisualizer, using official SAS 9.4 drivers.

DbVisualizer connects and lists schemas and tables.

However I see that there's something wrong in SQL statements that DbVisualizer issues to SAS (see second screenshot).

I think it would be nice to support SAS out of the box.



SAS-DB.png
(183 KB)

Great.


Please enable Debug DbVisualizer in Tools->Debug Window and the Debug tab and then re-run the operation that doesn't show any data. Then use Help->Contact Support in DbVisualizer to send the log file to us. Refer to this link in the new request: https://support.dbvis.com/discussions/topics/1000086288


Regards


Roger


Thank for your support, I have solved the 10.0.1 issue. SAS driver requires log4j.jar, which is present in 9.0.8 but not in 10.0.1. I have added this library, and now I can use the 10.0.1. DbVisualizer cannot still show tables, but apart for this everything works.

With 10.0.1 situation is worse: DbVisualizer does not even connect.

I will send logs for both situations.

Thank you again.



Thank you for your fast reply. I'l see.

Luca,


Great to hear you got connected.


Please note that SAS is not a supported database nor do we have any short-term plans to support it as there is low  demand for it.


I see you are using DbVisualizer Free 9.0.8 which is quite old. I first recommend that you upgrade to the latest 10.0.1 version. http://www.dbvis.com/download/


For the actual error(s), please enable Debug DbVisualizer in Tools->Debug Window and the Debug tab and then re-run the operation that causes the issue. Then use Help->Contact Support in DbVisualizer to send the log file to us. 


Regards


Roger

Login or Signup to post a comment