Start a new topic

home key is not moving the cursor home unless in selection mode (shift key)

version 10.0.3

linux ubuntu 16.04 (linux mint 18)


Unless i press shift the home key isn't moving the caret to the start of the line (as it should), or possible to the start of the line, excluding initial spaces and tabs. 


Thanks.


The keybinding for Insertion Point to Beginning of Text on Line is Home by default, so that sounds odd. Are you using the default key map? Does the Home button work as it should in other applications? Please see the User Guide for how to add or change keybindings:


http://confluence.dbvis.com/display/UG100/Changing+Keyboard+Shortcuts


Best Regards,

Hans

Hi,


I've also been experiencing the same issue for months when using the Home key to move the cursor to the beginning of a line:

  1. If I press the Home key --> it does nothing
  2. If I press the Home + Shift keys --> it selects the text from current position to the beginning of the line
  3. If I press the Home + Ctrl keys --> it moves to the first line
  4. If I press the End key --> It moves to the end the line
  5. If I press the End + Shift keys --> it selects the text from current position to the end of the line
  6. If I press the End + Ctrl keys --> it moves to the last line

So, while #2 through #6 behave as expected, it is clear that #1 does not. Because #1 is used very often, it makes it particularly an annoying bug.

Looking into the issue, I found that the Linux-UNIX key binding doesn't have any binding for the Home key:

image


Fortunately, I could solve the issue by copying the Linux-Unix key binding and setting the Home key manually:
image
Would it possible a solution for this issue for the next release?

Thank you!

Using:
  • Arch Linux: x86_64
  • Kernel: 4.19.4
  • Plasma: 5.14.4
  • Oracle JDK: 1.8.0_192
  • DbVis: 10.0.16

Good day.
The problem with using the Home key is not related to the keying of keys in Linux. The correct key operation in the code editor for the Home key occurs. But more often the Home key in the code editor does not work. Also note that in the mapping for it is not installed any operation.


Because the problem exists and I would like to use the key in the code editor as well as it works in other applications of the operating system.

All the best.

Login or Signup to post a comment