Start a new topic

Regression: Copy "File Data Type" value on Import File screen

When using "Import Data File" I used to be able to copy-and-paste values in the "File Data Type" column in the "Map Table Columns with File Columns" grid. This would allow me to change the "File Data Type" value for a large number of input columns at once (eg. make all input columns type "String"). Sometime in the DbVis 10.0 series this has stopped working. I first noticed it in version 10.0.6 (MacOS) but it's possible that I missed a few versions. The problem is still present in 10.0.7.

Could we get that back, please and thanks?


Just tried in 10.0.7 and it works fine.

Since the File Data Type when clicked is a drop-down with available types, you need to get out of the drop-down mode with ESC and then use the keyboard to extend or collapse the selection. Is that what you are doing?

You may also verify what keybindings are assigned to Copy and Paste by right-click in the grid.

If problem persist, please post a screenshot. 




Thanks for the reply. Pressing ESC makes no difference. I tried right-click as you suggest and both Copy and Paste are disabled on the popup menu (the key bindings are correct). Strangely, they're both active when I right-click on a value in the "Table Data Type" column (copy works and paste does nothing, as I would expect).

Were you testing on MacOS? I haven't had a chance to test on Windows yet.



My test was on macOS. The right-click actions are enabled only if there is at least one cell selected. See attached.

(I use the Linux keymap as opposed to the default macOS keymap. That explains the Ctrl+C and Ctrl+V key bindings in the screenshot.)



Curiouser and curiouser.

The main issue for me is that I can't seem to select the cells in that column. The first click on a cell selects the cell (on mouse button down) and opens the popup (on mouse button up). Clicking a value in the popup list or pressing ESC dismisses the popup and leaves the underlying cell unselected.

Selecting multiple cells by clicking then moving the mouse appears to work. I'm able to paste a value into the cells once I'm able to get them selected.

I'll try to do more testing tomorrow, perhaps on Windows or maybe a different JRE.


Login or Signup to post a comment