Start a new topic

10.0.8 graphical issues -- aliasing, mis-sized fonts, and more

Immediately after upgrading to 10.0.8, I have had a host of graphical issues with DBVisualizer. The most severe problem is that SQL Commander's font display size appears to be different from the actual text size. The result of this is that when I click and drag on SQL Commander text, the actual selection area begins several characters to the right of where my mouse clicked. For example, in the screenshot below, I clicked to the right of the period and dragged left over the word "aliqua", but text selected and copied to the clipboard is ". Ut eni".



Other graphical artifacts you may be able to see in the screenshot:

* bad aliasing on icons, especially the >

* fuzzy text

* "drop shadows" behind tabs, like they have a double border

* Just under the title bar, I can see a one-pixel row which is from the last window I alt-tabbed to -- the open tabs in Firefox, or a black line if I was in Putty.

I am on Windows 7, the same as all my coworkers, who have not had any issues. 

I have tried changing my theme, did not notice a difference.

One thing I do that many don't is keep my Windows taskbar on the left side instead of the bottom, in case that made it resize.

This happened immediately after upgrading to 10.0.8 and has persisted for a week and several reboots.


The following is from the solution article:

Java 9 is included starting with DbVisualizer 10.0.8 for the first time, with support for HiDPI displays. Unfortunately we have found that Java 9 causes an issue in the editor where the insertion point (caret) doesn't align with where the mouse cursor is clicked. The problem is in Java 9 and visible both with non HiDPI and HiDPI monitors. Hopefully a future Java 9 release will fix it, but for now there are several workarounds:

1) If using an HiDPI monitor

Do as follows if you are experiencing the problem with a HiDPI monitor:

  1. Find java.exe you use, or the dbvis.exe file if using the launcher in Windows File Explorer.
  2. Right click -> Properties
  3. Go to Compatibility tab
  4. Check Override high DPI scaling behavior.
  5. Choose System for Scaling performed by. Choosing System (Enhanced) seems to be a little better.

2) If using a non HiDPI monitor

In Tools->Tool Properties and in the General category insert the following on a new line in Java VM Properties:


The setting will force the resolution for Java to 100% and ignore any higher resolution defined in Windows. To change the resolution in DbVisualizer click the General / Appearance / Fonts category. Change Font Scale to the same resolution that is set in Windows and restart. If you after restart need to adjust the font sizes even further, open Tools->Tool Properties and the General / Appearance / Fonts.

3) ... or change to the Monospaced font

The following is applicable for both HiDPI and non HiDPI monitors.

In Tools->Tool Properties select General / Appearance / Fonts and change the font for Text Editors to the Monospaced font. 

If any of these doesn't give the expected behavior, please post a screenshot.



1 person likes this

Thank you for the quick help. I never would have found that search term since I was thinking mainly about the anti-aliasing. 

The reason this applied to me and not my coworkers is that I scale WIndows to 125% (medium). Point 3 did not work for me alone, but point 2 worked fine. 

After setting the scale to 1 and the font size to 125%, I also boosted the size of the Consolas font to 14. That made the SQL commander just about the same size as it was before.

Great to hear the workaround worked for you.



Login or Signup to post a comment