Start a new topic

Save preference: strip comments when executing

When I re-open the software or simply open a new tab (command+T)... the strip comments selection is no longer selected.  This means I have to select it every time I want to run a new query in a new tab. That is crazy. How can I save that setting? And why does it cause an issue at all? For instance, a comment in any other programming language is exactly that: a comment. There is no special command needed to tell the language to ignore it. It just happens. Why must I tell dbviz to ignore comments?

Josh,


In the connection Properties tab for your database connection under the SQL Commander category, you can enable Strip Comments when Executing among other settings. You may also do this for all your connections of a specific type in Tools->Tool Properties and the Database tab. Select the database type and then do necessary changes under the SQL Commander category. 


Some databases handles comments just fine while others don't. The strip comments feature in DbVisualizer is available to handle these cases. 


Regards


Roger




Ah, interesting, thanks. I appreciate the swift response.

Login or Signup to post a comment