Start a new topic

unable to create file unpack200

I just went to upgrade my version of dbvisualizer and get stuck when unpacking files

I get the error /Applications/ Could not create this file. Shall I try again?

Hitting yes just brings the error up again

I am an elevated user while installing

I am using macOS Mojave version 10.14

I was able to "fix" this by installing to the Documents directory


Thanks for the update.




I have the save issue, with the same macOS version.  Is there any other solution for this, then besides installing in a different directory?


I managed to get passed all error messages, by via finder changing the file and folder permissions to 777 instead of 775.
But them all of a sudden the application will not start anymore....

Running the install again or rebooting the Mac didn't solve the issue.  Please help...


Try install in a brand new folder.



Installing in a brand new folder really isn't a sufficient answer. I get this error every time I try to upgrade DbVisualizer. If I install DbVisualizer in a brand new directory, the new install doesn't keep any of my Connection settings. And exporting and re-importing the Connections is a serious pain.

I found that recursively changing the ownership of to me worked:

sudo chown -R $(whoami) /Applications/

1 person likes this


Your settings including connection definitions are not stored with the software. They are stored in ~/.dbvis. Installing in a new folder shouldn't be an issue based on that. 



 I agree with Malina that users shouldn't have to choose different directories for upgrades. I can also confirm that Malina's chown suggestion appears to have worked on mac 10.14.6. I hope someone at dbvis reads this thread and addresses the upgrade snag that still exists.


What you and others experience in this thread is a rare condition that we are unable to reproduce. 

If it happens again, please open a Terminal window and goto the folder you are installing in and run:

find . -name '*' -print -exec ls -l {} \; > /tmp/dbvis.log

Then post the /tmp/dbvis.log file here as an attachment or email to referring the link to this forum post.

Since you say this happens every time you upgrade, try run the installer one more time to verify and follow the steps highlighted above.



Installation was a success, when I manually deleted dbvisualizer from Applications and then installed the new version. I did not lose any of my settings nor connection configurations.

Login or Signup to post a comment