Start a new topic

Prevent filter being applied on initial table load

 Hi,


Apologies if this option exists already but I was unable to find it anywhere.


I'm using DbVisualizer Pro 10.0.25 [Build #3025] and currently when I open a table DBViz will automatically apply the last filter that was used. If the filter is one that takes a considerable time to execute, I'm stuck waiting until it finishes. Otherwise I have to grapple with killing the connection, clearing the filter and then reconnecting before refreshing.


It would be great to have an option to use no filter on initial load, so that DBViz just uses the set max rows when first opening the table.


Thanks


Hi Ben,


As far as I know, there is no such option in current version. I will register this as a feature request and we will look into it.


Thanks for taking the time to suggest this!


regards / Peer

Hi Ben,


I am jumping in here. There is the setting Max Rows at First Display in Tools->Tool Properties under the General / Data Tab category. It is used how many rows should be displayed when the Data tab is first displayed for a table. Setting it to 0 will not load any rows at all. 


However, I believe setting it to 0 is still not a perfect fit for you as it will  run the query but ignore getting any results. 


Please confirm.


Regards


Roger

Thanks for the suggestion Roger, I set the value to 0 but as you suspected DBViz still tries to apply the filter before returning 0 rows after the query has finished.

Ben,


Just to inform you that we have just released a beta version of the upcoming DbVisualizer 11.0 with support to disable filters from being part of the SELECT if limiting number of rows in the Data tab at first display.


Download here: https://www.dbvis.com/beta/


You find the option in Tools->Tool Properties under the General / Table Data category.


I hope this is what you are looking for.


Regards


Roger

Hi Roger, that option worked perfectly. Thanks for the prompt fix!

Login or Signup to post a comment